Commandes cisco de base pour les configurations partie 2

Voici la deuxième partie des commandes Cisco de base pour les configurations. Si vous avez raté la première partie, cliquez ici pour aller consulter cela.

Les access liste pour les adresses IPv4

Pour réduire donc les termes longs, vous allons utiliser des abréviations ici. Voici donc la légende des abréviations que nous allons utiliser :

MG : Masque Génirique.

IPsrc : l’adresse IP source.

IPdst : l’adresse IP destination.

Access liste standard numéroté

R1(config)#access-list [1-99] [permit/deny] [@IPsrc MG/any] 
R1(config)#access-list 1 permit 192.168.4.0 0.0.0.255

Définir une access liste étendue numérotée

R1(config)#access-list [100-199] [permit/deny] [protocole] [@IPsrc MG/any] [@IPdst MG/any] [eq N°]
R1(config)#access-list 100 permit tcp 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255 eq 80

Une access liste standard nommée

R1(config)# ip access-list standard nom
R1(config-std-nacl)# [permit/deny] [@IPsrc MG/any]
R1(config-std-nacl)# permit 192.168.1.0 0.0.0.255

Ajouter une access liste étendue nommée

R1(config)# ip access-list extended nom
R1(config-ext-nacl)# [permit/deny] [protocole] [@IPsrc MG/any] [@IPdst MG/any] [eq N°]
R1(config-ext-nacl)# permit tcp 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255 eq 80

Appliquer une liste de controle d’accés sur interface

R1(config)# interface g0/1
R1(config-if)# ip access-group [N°/nom] [in/out]
R1(config-if)# ip access-group 100 in

Appliquer une liste de controle d’accés sur une ligne

R1(config)# line vty 0 4
R1(config-line)# access-class [N°/nom] [in/out]
R1(config-line)# access-class 100 in

Les access liste IPv6:

Une access liste étendues nommée

R1(config)# ipv6 access-list nom
R1(config-ipv6-acl)# [permit/deny] [protocole] [@IPv6 src /any] [@IPv6 dst /any] [eq N°]
R1(cpnfig-ipv6-acl)# permit tcp 2001:DB8:ACAD:1::/64 2001:DB8:ACAD:1::/64 eq 80

Appliquer une liste de controle d’accés sur une interface

R1(config-if)# ipv6 traffic-filter nom [in/out]

Configuration du DHCPv4 :

Excludes une plage d’addresses, par exemple 10 adresses

R1(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.10

Création d’un pool DHCP

R1(config)# ip dhcp pool nom

Ajout le réseau au pool

R1(dhcp-config)# network 192.168.1.0 255.255.255.0

Ajout de l’addresse de la passerelle par défaut

R1(dhcp-config)# default-router 192.168.1.1

Définir l’addresse du serveur DNS

R1(dhcp-config)# dns-server 192.168.1.5

Ajout le nom de domaine

R1(dhcp-config)# domain-name dir-tech.com

Configurez une interface pour obtenir une adresse auprès du serveur DHCP

R2(config)# interface G0/1
R2(config-if)# ip address dhcp

Configurez le relais DHCP sur une interface

R2(config)# interface G0/2
R2(config-if)# ip helper-address 192.168.10.5

Configuration du DHCPv6 (adresses IPv6)

Configurez le relais DHCP sur une interface de routeur

R2(config-if)# ipv6 dhcp relay destination 2001:DB8:CAFE::1

Configuration de SLAAC:

Activation du routage IPv6

R1(config)# ipv6 unicast-routing

Activer l’option SLAAC sur une interface

R1(config)# interface G0/1
R1(config-if)# no ipv6 nd managed-config-flag
R1(config-if)# no ipv6 nd other-config-flag

Configuration de DHCP sans état :

Activation du routage monodiffusion IPv6

R1(config)# ipv6 unicast-routing

Configuration d’un pool DHCP

R1(config)# ipv6 dhcp pool nom

Configurez l’adresse du serveur DNS

R1(dhcp-config)# dns-server 2001 :DB8 :10 ::5

Ajoutez le nom de domaine

R1(dhcp-config)# domain-name dir-tech.com

Configuration de l’interface DHCP sans état

R1(config)# interface G0/1
R1(config-if)# ipv6 dhcp server nom
R1(config-if)# ipv6 nd other-config-flag

Configurez d’une interface en tant que client DHCP sans état

R2(config)# interface G0/1
R2(config-if)# ipv6 enable
R2(config-if)# ipv6 address autoconfig

Configuration de DHCP avec état :

Activation du routage monodiffusion IPv6

R1(config)# ipv6 unicast-routing

Configuration d’un pool DHCP

R1(config)# ipv6 dhcp pool nom

Configurez l’addresse de prefix

R1(config-dhcp)# address prefix 2001 :DB8 :CAFE :1 ::/64 lifetime infinite

Configuration de l’addresse du serveur DNS

R1(config-dhcp)# dns-server 2001 :DB8 :CAFE :AAAA ::5

Ajouter le nom de domaine

R1(config-dhcp)# domain-name dir-tech.com

Configuration de l’interface DHCP avec état

R1(config)# interface G0/1
R1(config-if)# ipv6 dhcp server nom
R1(config-if)# ipv6 nd managed-config-flag

Définir une interface en tant que client DHCP avec état

R2(config)# interface G0/1
R2(config-if)# ipv6 enable
R2(config-if)# ipv6 address dhcp

NAT pour les adresses IPv4 :

Configuration de la NAT statique

R1(config)# ip nat inside source static 192.168.10.254 209.165.201.5

Configurez l’interface NAT appropriée

R1(config-if)# ip nat [inside/outside]

Configuration de la NAT dynamique

Définissez un pool d’adresses IP publiques

R1(config)# ip nat pool nom 209.165.200.226 209.165. 200.240 netmask 255.255.255.224

Définissez les adresses pouvant être traduites

R1(config)#access-list 1 permit 192.168.0.0 0.0.255.255

Reliez le pool à l’ACL

R1(config)# ip nat inside source list 1 pool nom

Configurez l’interface NAT appropriée

R1(config-if)# ip nat [inside/outside]

Configuration de la PAT (pool d’adresses)

Définissez un pool d’adresses IP publiques

R1(config)# ip nat pool nom 209.165.200.226 209.165. 200.240 netmask 255.255.255.224

Définissez les adresses pouvant étre traduites

R1(config)#access-list 1 permit 192.168.0.0 0.0.255.255

Reliez le pool à l’ACL

R1(config)# ip nat inside source list 1 pool nom overload

Configurez l’interface NAT appropriée

R1(config-if)# ip nat [inside/outside]

Configuration de la PAT (adresse unique)

Identifiez une interface externe comme étant d’adresse globale interne à surcharger via l’ACL 1

R1(config)# ip nat source list 1 interface S0/0/0 overload 

Définissez les adresses pouvant être traduites

R1(config)# access-list 1 permit 192.168.0.0 0.0.255.255

Configurez l’interface NAT appropriée

R1(config-if)# ip nat [inside/outside]

Établit la traduction statique entre une adresse local interne et un port local et entre une adresse global interne et un port global.

R1(config)# ip nat inside source static [protocole] [@IP local] [N°] [@IP global] [N°]
R1(config)# ip nat inside source static tcp 192.168 .10.254 80 209.165.200.225 80

Configuration des EtherChannel :

Créez l’interface de canal de port

S1(config)# interface range f0/1-2
S1(config-if)# channel-group 1 mode active

Configurez port channel 1 en tant que trunk

S1(config)# interface port-channel 1
S1(config-if)# switchport mode trunk

Configuration du STP :

Configurer le cout de port

S1(config)# interface F0/1
S1(config-if)# spanning-tree cost 5

Définir S1 en tant que pont racine principal

S1(config)# spanning-tree vlan 1 root primary

Définir S2 en tant que pont racine secondaire

S2(config)# spanning-tree vlan 1 root secondary

Modifier la priorité de pont

S1(config)# spanning-tree vlan 1 priority 24576

Définir un portfast sur une interface

S1(config)# interface F0/1
S1(config-if)# spanning-tree portfast

$Configurez portfast sur toutes les interfaces non-trunk

S1(config)# spanning-tree portfast default

Configurez la protection BPDU sur une interface

S1(config-if)# spanning-tree bpduguard enable

Ajouter la protection BPDU sur tout les interface qui utilise portfast

S1(config)# spanning-tree bdpuguard default

Définissez root guard sur une interface

S1(config-if)# spanning-tree guard root

Configurez Rapid PVST+

S1(config)# spanning-tree mode rapid-pvst

Specifies le type de liaison pour une interface

S1(config-if)# spanning-tree link-type point-to-point

Configuration de EIGRPv2:

Activez et passer en mode de configuration EIGRP

R1(config)# routeur eigrp 1

Attribuer un ID de routeur

R1(config-router)# eigrp router-id 1.1.1.1

Annoncez les réseaux EIGRP

R1(config-router)# network 192.168.1.0 255.255.255.0
R1(config-router)# network 192.168.2.0 255.255.255.0

Configurez l’interface passive

R1(config-router)# passive-interface G0/1

Modification de la bande passante d’interface

R1(config)# interface S0/0/0
R1(config-if)# bandwidth 64

Activez la récapitulation automatique

R1(config-router)# auto-summary

Configurez des routes récapitulatives manuelles

R1(config)# interface S0/0/0
R1(config-if)# ip summary-address eigrp 1 192.168.0.0 255.255.255.252.0

Propagation des routes statique par défaut

R1(config-router)# redistribute static

Configurez les pourcentages de bande passante utilisée par EIGRP

R1(config-if)# ip bandwidth-percent eigrp 1 40

Modification des intervalles

R1(config-if)# ip hello-interval eigrp 1 50
R1(config-if)# ip hold-time eigrp 1 150

Modifiée la valeur de paths

R1(config-router)# maximum-paths 8

Créez une chaine de clés et d’une clé

R1(config)# key chain nom
R1(config-keychain)# key 1
R1(config-keychain-key)# key-string cisco

Configurez l’interface pour utiliser l’authentification MD5

R1(config-if)# ip authentication mode eigrp 1 md5

Configurez l’interface pour utiliser la chaine de clés

R1(config-if)# ip authentication key-chain eigrp 1 nom

Configuration du EIGRPv3 :

Activez le routage monodiffusion IPv6

R1(config)# ipv6 unicast-routing

Passer en mode de configuration EIGRP

R1(config)# ipv6 router eigrp 1

Attribuer un ID de routeur

R1(config-rtr)# eigrp router-id 1.1.1.1

Activez le processus eigrp R1

R1(config-rtr)# no shutdown

Activation du protocole EIGRP sur une interface

R1(config)# interface G0/0
R1(config-if)# ipv6 eigrp 1

Configurez l’interface passive

R1(config-rtr)# passive-interface G0/0

Modification de la bande passante d’interface

R1(config)# interface S0/0/0
R1(config-if)# bandwidth 64

Configuration d’une route recapitulative manuelle

R1(config-if) ipv6 summary-address eigrp 1 2001:DB8:ACAD::/48

Propagation des routes statique par défaut

R1(config-rtr)# redistribute static

Configurer le pourcentage de bande passante utilisé par EIGRP

R1(config-if)# ipv6 bandwidth-percent eigrp 1 40

Modification des intervalles

R1(config-if)# ipv6 hello-interval eigrp 1 50
R1(config-if)# ipv6 hold-time eigrp 1 150

Créez une chaine de clés et d’une clé

R1(config)# key chain nom
R1(config-keychain)# key 1
R1(config-keychain-key)# key-string cisco

Configurez l’interface pour utiliser l’authentification MD5

R1(config-if)# ipv6 authentication mode eigrp 1 md5

Configurez l’interface pour utiliser la chaine de clés

R1(config-if)# ipv6 authentication key-chain eigrp 1 nom

Configuration du PPP :

Activez l’encapsulation PPP sur une interface

R1(config)# interface S0/0/0
R1(config-if)# encapsulation ppp

Configurer la compression sur PPP

R1(config-if)# compress [predicto/stac]

Configurez LQM PPP (controle de la qualité de liaison)

R1(config-if)# ppp quality 90

Configuration de l’authentification PAP

Configurez l’authentification PAP sur une interface

R1(config-if)# ppp authentication pap

Définir le nom d’utilisateur distant R1 et le mot de passe

R1(config-if)# ppp pap sent-username nom password motdepasse

Configurez le nom d’utilisateur distant R2 et le mot de passe

R1(config)# username nom password motdepasse

Configuration de l’authentification CHAP

Configurez l’authentification CHAP sur une interface

R1(config-if)# ppp authentication chap

Configurez le nome d’utilisateur distant de R2 et le mot de passe

R1(config)# username nom password motdepasse

Configuration du Frame relay

Activez l’encapsulation frame relay sur une interface

R1(config)# interface S0/0/0
R1(config-if)# encapsulation frame-relay

Désactivé ARP inverse

R1(config-if)# no frame-relay inverse-arp

Faire du mappage statique

R1(config-if)# frame-relay map ip 10.1.1.1 102

Configuration de type de lmi

R1(config-if)# frame-relay lmi-type [ansi/cisco/q933a]

Configuration de sous interface

R1(config)# interface serial S0/0/0.101 [multipoint/point-to-point]

Attribution d’un DLCI à une sous interface

R1(config-subif)# frame-relay interface-dlci 101

Supprimer des mappages Frame Relay

R1# clear frame-relay inarp

Configuration du VPN

Configuration de tunnel GRE

Créez une interface de tunnel

R1(config)# interface tunnel 0

Spécifiez que le mode de l’interface du tunnel est GRE sur IP

R1(config-if)# tunnel mode gre ip

Configurez une adresse IP pour l’interface du tunnel

R1(config-if)# ip address 192.168.2.1 255.255.255.0

Spécifies l’adresse IP source du tunnel

R1(config-if)# tunnel source S0/0/0

Spécifies l’adresse IP de destination du tunnel

R1(config-if)# tunnel destination 198.133.219.87

Syslog

Afficher dans les événements le temp écoulé depuis le dernier démarrage

S1(config)# service timestamps log uptime

Afficher dans les événements la date et l’heure

S1(config)# service timestamps log datetime

Configurez l’adresse IP du serveur Syslog

S1(config)# logging 192.168.1.3

Limité les messages qui seront envoyés au serveur Syslog

S1(config)# logging trap 4

Configurer l’interface source

S1(config)# logging source-interface g0/0

Configuration de SNMP

Configurez l’identifiant de communauté et le niveau d’accès

R1(config)# snmp-server community nom [ ro/rw ] SNMP_ACL

Définir l’emplacement du périphérique

R1(config)# snmp-server location NOC_SNMP_MANAGER

Ajouter le contact du systéme

R1(config)# snmp-server contact adam

La destination des opérations de déroutement SNMP et l’identifiant de communauté

R1(config)# snmp-server host 192.168.1.3 version [ 1/2c/3 ] nom

Activer les déroutements SNMP

R1(config)# snmp-server enable traps

Créer une ACL nommée standard SNMP_ACL et autoriser l’adresse 192.168.1.3

R1(config)# ip access-list standard SNMP_ACL
R1(config-std-nacl)# permit 192.168.1.3

Crée un nouveau groupe SNMP sur le périphérique

R1(config)# snmp-server group nomgroupe [ v1/v2c/v3 ]

Ajouter un nouvel utilisateur au groupe SNMP

R1(config)# server-snmp user username nomgroupe v3 auth [ md5/sha] password

Utilisation de NetFlow

Capturez les données NetFlow pour la surveillance des paquets entrants sur l’interface

R1(config-if)# ip flow ingress

Capturez les données NetFlow pour la surveillance des paquets sortants sur l’interface

R1(config-if)# ip flow egress

Adresse IP et numéro de port UDP du collecteur NetFlow

R1(config)# ip flow-export destination 192.168.1.3 2055

Version de NetFlow à utiliser lors du formatage des enregistrements NetFlow envoyés au collecteur

R1(config)# ip flow-export version 5

Interface source à utiliser donc en tant que source des paquets envoyés au collecteur

R1(config)# ip flow-export source N°

Trouver un nom de domaine gratuitement

Répandre l'amour

Adam Guipelbé

Ingénieur Systèmes et Réseaux

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.